make deb and make tgz works now (RPM directory not up-to date)
[svn/Prometheus-QoS/.git] / debian / prometheus.debian
similarity index 53%
rename from prometheus.debian
rename to debian/prometheus.debian
index d5487e59e50610eb8e08e18a35aa7a68bbf7efce..c17d10c5cb819212c788f27bfac2fa3b94e55488 100755 (executable)
@@ -1,9 +1,10 @@
 #!/bin/bash
 
 arch=`dpkg-architecture -qDEB_HOST_ARCH`
-version=`grep VERSION Makefile | gawk -F= '{ print $2 }'`
-package=`grep PACKAGE Makefile | gawk -F= '{ print $2 }'`
-maintainer='gandalf <gandalf@arachne.cz>'
+version=`grep VERSION= Makefile | cut -d = -f 2`
+package=`grep PACKAGE= Makefile | cut -d = -f 2`
+maintainer="gandalf <gandalf@arachne.cz>"
+control=debian/prometheus.control
 
 #patch -Nl <debian/prometheus.patch
 
@@ -11,7 +12,6 @@ sed     -e "s/__ARCHITECTURE__/$arch/" \
         -e "s/__VERSION__/$version/" \
         -e "s/__PACKAGE__/$package/" \
         -e "s/__MAINTAINER__/$maintainer/" \
-        debian/prometheus.control > debian/control
+        $control > debian/control
 
-dpkg-buildpackage
                                
This page took 0.113727 seconds and 4 git commands to generate.